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BEFORE WE BEGIN...



LEARNING GOALS

1. Become familiar with and know how to navigate between the different
windows in SPSS

2. Know how to write a data file
3. Know how to import data
4. Identify errors and strange or even impossible measurements in a data set
5. Describe data using descriptive statistics that you calculate using SPSS (and

know what these statistical measures can tell you)
6. Present data using graphs made in SPSS
7. Manipulate data (re-structure, re-code, calculate new variables from original

variables)
8. Know how to easily and efficiently document everything you do in SPSS, and

re-use your own methods
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TECHNICAL PREREQUISITES

If you have not got SPSS installed on your own device, use remote desktop or go
to view.uio.no and log on with your UiO username and password.

The data files used for examples are either from the SPSS survival manual, or are
fictitious data that I have made. These files can be downloaded as a single .zip file
from the course website.

Try to do what I do, and follow the same steps. If you missed a step or have a
question, don’t hesitate to ask.
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GETTING STARTED



WHAT IS SPSS?

SPSS is short for for Statistical Package for the Social Sciences

The different windows

1. Output

2. Syntax

3. Data view

4. Variabel view
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OUTPUT

Shows all commands that have been executed, and the corresponding results and
outputs of those commands. This is where you will find the tables and graphs you
produce.

This output can be saved as a .spv file (which can only be opened using SPSS), or
exported as .ppt, .xls, .doc, .pdf, etc.
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SYNTAX

The syntax file is the easiest way to keep track of everything you do, and it enables
you to go back and either re-examine your analysis, or run the same analysis
again.
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SYNTAX

SPSS allows for automatic pasting of every single procedure you run, or
alternatively, you can type in procedures yourself.
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SYNTAX

It also makes it easier to run the same procedure on different data sets and to run
the same procedure multiple times.

You run syntax by
clicking the green
arrow button. If
you only want to
run part of the
syntax, highlight
that part and click
the green arrow.

It can be saved as a .sps file, and can be opened by any simple text editor, like
Notepad. 7



SYNTAX

Colour coding

• Dark blue - Procedures

• Green - Sub-routines, connected with a procedure

• Red/Orange - Key words indicating choices you have made

• Grey - Comments (the line must begin with *)

• Black - Variable names
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DATA VIEW
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DATA VIEW
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VARIABLE VIEW
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VARIABLE VIEW
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THE DIFFERENT TYPES OF VARIABLES IN SPSS

• Nominal - This is a variable coded as a set of numbers, but where the
numbers in themselves mean something else, e.g. gender (male: 1, female:
2), answer (yes: 1, no: 0).

• Ordinal - A variable where data is coded as numbers, like with nominal, but
where the codes can be arranged in a meaningful order, e.g. How much do
you agree with this statement, what is your highest achieved level of
education, etc.

• Scale - Numbers, where the number itself is the data, e.g. age, blood
pressure, temperature, number of points achieved in a test, etc.
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ALL THE OTHER VALUES THAT DEFINE A VARIABLE

• Name - variable name (has to start with a letter (a-z))

• Type - numeric, string, date, i.e. number, words, dates, etc.
• Width - how many characters will this variable need?
• Decimals - how many decimals do you need?
• Label - "longer" description of the variable
• Values - for nominal and ordinal: this is where you code your variable
• Missing - if you want to give missing data a different code than the default

(empty cell)
• Columns - how wide do you want the column to be
• Align - right or left alignment within the column
• Measure - this is where you choose scale, nominal or ordinal
• Role - Give a predefined role from the start (if you want to), e.g. dependent or

independent variable (not necessary)
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ACTIVE WINDOW

Especially when you have several files/data sets open at the same time, it is
important to know which spreadsheet is the active one, as this is the one that will
be used in the analysis you do. SPSS indicates which is the active window with a
small cross in the top left corner.
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SHORTCUTS

Icon Descrition

Open file

Save file

Print

Most recent
procedures

Undo

Redo

Go to case

Icon Description

Go to vari-
able

Variable in-
formation

Descriptive
statistics

Find/search

Insert case

Insert vari-
able

Split file

Icon Description

Weight cases

Select cases

Choose if
data or label
is shown

Use subset

Show all vari-
ables

Spell check
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DATA MANAGEMENT IN SPSS



OPEN AN EXISTING DATA FILE

File > Open > Data

In SPSS, data files have the file
extension .sav

Choose Paste, not Open. This will
paste the corresponding
commands into the syntax file. Go
to the syntax window, mark the
text, and click on the Run selection
button (green triangle).
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IMPORTING DATA - TEXT FILE

File > Import Data > Text Data

This dialogue box allows you to open .txt, .dat, .csv, and .tab files.
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IMPORTING DATA - TEXT IMPORT WIZARD STEP 1 OF 6
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IMPORTING DATA - TEXT IMPORT WIZARD STEP 2 OF 6
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IMPORTING DATA - TEXT IMPORT WIZARD STEP 3 OF 6
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IMPORTING DATA - TEXT IMPORT WIZARD STEP 4 OF 6
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IMPORTING DATA - TEXT IMPORT WIZARD STEP 5 OF 6
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IMPORTING DATA - TEXT IMPORT WIZARD STEP 6 OF 6

Remember to go to
your syntax file and run
the latest bit of code
added to it. This will
actually import the data
file.
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IMPORTING DATA - CSV

File > Import Data > CSV
Data
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IMPORTING DATA - XLS/XLSX

File > Import Data > Excel
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DATA VIEW - SPLIT VIEW

When you have very large data
sets, it can be useful to ’split’ the
screen, so that you get four panels,
all showing different sections of the
spreadsheet.

Window > Split
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EDITING A DATA FILE

Delete or insert cases or variables when you are in Data View

Remember to save the edited file with a new name, so the original data file is
unaltered.
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EDITING A DATA FILE

Other ways to delete or insert cases or variables
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CHANGING VARIABLE PROPERTIES

Data > Define Variable
Properties

It is better to use this method
than to do it directly in
Variable View, as you have
the possibility of
documenting the changes
you make, with the Paste
function.
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SORTING CASES

Data > Sort cases
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MERGE TWO DATA FILES - ADDING CASES

Data > Merge Files > Add
Cases

We have two options when
merging files; to add cases
or to add variables. We will
use files fil1, fil2 and fil3.

32



MERGE TWO DATA FILES - ADDING CASES

Choose either an open file (if the file you need is open), or select an external file
(has to be .sav format)
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MERGE TWO DATA FILES - ADDING CASES

To merge files, but only with mutual variables. All other variables are excluded.
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MERGE TWO DATA FILES - ADDING CASES

To merge files, with all variables, even if the variable is only found in one of the
data sets
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MERGE TWO DATA FILES - ADDING CASES

To merge files, with all variables, where variables that are only found in one of the
sets can be merged with a variable only found in the other set. Use the Pair button
rather than the arrow.
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MERGE TWO DATA FILES - ADDING VARIABLES

Data > Merge Files > Add
Variables...

Here we use files fil1 and fil3. First
the method of merging must be
selected. One-to-One merge
based on key values is default and
gives all cases, from both files. A
common variable is used as key, to
link corresponding cases together.
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MERGE TWO DATA FILES - ADDING VARIABLES
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MERGE TWO DATA FILES - ADDING VARIABLES

One-to-One merge based on file order results in a dataset containing all cases
found in fil1, but excludes cases that are only found in fil3.
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MERGE TWO DATA FILES - ADDING VARIABLES

One-to-Many merge based on key values has two options; where choosing the
data set corresponding to fil3 will give the same result as One-to-One merge
based on file order. If you choose the data set corresponding to fil1, you get only
the cases found in fil3, with cases only found in fil1 excluded.
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SPLIT DATA SET

Data > Split File

Choose Compare groups if you want data from different groups displayed in the
same table. Choose Organize output by groups if you want results from different
groups in separate tables.
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DEFINE A SUBSET FROM LARGE SETS

Utilities > Define Variable Sets

The new set can contain as many of the original variables as you want.
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DEFINE A SUBSET FROM LARGE SETS

The new subset needs a name.
Remember to click Add set before
you close the dialogue box. If you
don’t, the new set you defined is
not saved, and you have to define
it again.
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USING A SUBSET

Utilities > Use Variable Sets: In order to work with the new subset, select it from
the list of available sets. When you wish to go back to working with the entire set,
choose ALLVARIABLES in the same dialogue box.
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SELECTION OF DATA BASED ON A CONDITION

Data > Select cases: When you wish to make a more specific selection than you
can achieve with the split file option.
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SELECTION OF DATA BASED ON A CONDITION

Select Cases: If

Choose which cases you want. As an example, here we select all men over 50.
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SELECTION OF DATA BASED ON A CONDITION

Select Cases: All cases

When you want to go back to looking at all cases again, remember to go through
the same dialogue box, but select All cases.
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BEFORE WE BEGIN TO ANALYZE OUR

DATA...



IS EVERYTHING CORRECT?

In case of data import, does it look correct? Are variables coded correctly?

For this part we use the file error.sav

Categorical variable: Analyze > Descriptive statistics > Frequencies
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IS EVERYTHING CORRECT?

We get two tables. Statistics gives the number of valid data entries, number of
missing values, maximum and minimum values. The other table tells us how many
cases that have not been coded correctly.
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IS EVERYTHING CORRECT?

Continuous variable: Analyze > Descriptive statistics > Descriptives
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IS EVERYTHING CORRECT?

The table gives amongst other things, maximum and minimum values, which can
tell us if someone are outside of the possible range. In this case, at least one
person has an age which is wrong, as all participants are over 18.

If you make any changes to the data, remember to document it
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DESCRIPTIVE STATISTICS



THE DIFFERENCE BETWEEN A SAMPLE AND A POPULATION

We use statistics to say something about a population as a whole, based on
results from a sample.

Even though a sample is randomly chosen and representative of the population,
there will always be small individual variations, which can give rise to slightly
different results each time an experiment is carried out.

This means that our results can be a bit different from the true values of the
population.

The greater the sample, the closer we are likely to be to the true values. Rule of
thumb: have at least 30 cases, ideally many more. If there is much variation, or if
you are looking for small differences or effects, you need more cases.
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IMPORTANT STATISTICAL MEASURES

• Frequency and relative frequency - how many fall into each category, have
answered yes or no, how many are men how many women, etc.

• Mode - the most common value or category you measure. There can be more
than one mode.

• Mean - the average. The mean does not have to be a value you have actually
measured.

• Median - the middle measurement when data are arranged in ascending
order.
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IMPORTANT STATISTICAL MEASURES

• Standard deviation and standard error - the variation or spread in the data,
deviation from the mean.

• Skewness - deviation from symmetry.
• Kurtosis - long tails and pointy distribution, or short tails and data mostly

found around or close to the mean.
• Percentiles - value below which a certain percentage of the data are found,

e.g. the 25% percentile indicates the value marking the upper limit of the
lower 25% of the data.

• Interquartile Range (IQR) - the middle half of the data.
• Confidence interval (CI) - interval estimate rather than a point estimate of a

statistical measure. If we conduct the same experiment many times, then the
95% CI for the mean will in 95% of the experiments contain the true mean of
the population.
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CATEGORICAL VARIABLES

Analyze > Descriptive Statistics > Frequencies

• Frequencies gives a
frequency table and
useful plots for
categorical variables

• The tick box Display
Frequency Tables is
ticked by default

• Several variables can be
studied at the same time
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CATEGORICAL VARIABLES

Frequencies: Statistics og Frequencies: Charts
None of these statistical
measures are appropriate for
categorical variables. You
can tick Mode, but this
measure can just as easily
be identified from a graph or
a frequency table.
The most useful graphs for
categorical variables are
either bar or pie charts.
Choose whichever you
prefer.
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CATEGORICAL VARIABLES - OUTPUT

The tables in the output show the
number of cases included in total,
and a frequency table for each of
the variables included in the
analysis. This provides you with
both relative and regular frequency
of each category.

57



CATEGORICAL VARIABLE - OUTPUT

Bar chart of marital status.
Here we can clearly see that
Married first time is the
mode. In addition we get a
good overview of how the
participants in this study are
distributed over the different
categories.
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CONTINUOUS VARIABLES

Analyze > Descriptive Statistics > Frequencies

Frequencies can also be
used for continuous
variables. Just remember to
de-select Display frequency
tables, otherwise your output
will start with a very large
table containing the
frequencies for each of the
measured values in the
continuous variables.
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CONTINUOUS VARIABLES

With continuous variables
you can select all the
statistical measures that
were ill suited for categorical
variables, like mean,
standard deviation, etc.
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CONTINUOUS VARIABLES

Frequencies: Charts

Bar and pie charts are less
useful for continuous
variables, but histograms are
very useful. Tick the box that
says Show normal curve on
histogram, in order to get an
indication of whether the
variable is close to a normal
distribution or not.
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CONTINUOUS VARIABLES - OUTPUT

The table produced by the
Frequencies-procedure gives a
good overview of much descriptive
statistics concerning these
variables. This is very useful to go
through before starting more
complicated procedures and
analyses.
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CONTINUOUS VARIABLES

The histogram with the normal curve indicates fairly easily how well the data fit
with a normal distribution.
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CONTINUOUS VARIABLE

For continuous variables we also have a different option.

Analyze > Descriptive Statistics > Descriptives

This option is particularly useful if
you wish to compare several
continuous variables. In addition, it
can be used to create new
variables containing the data
converted to a standard normal
distribution (z-transform). This in
turn can be useful when screening
for outliers.
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CONTINUOUS VARIABLES

Descriptives: Options

Many of the same options as
in Frequencies can also be
selected here.
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CONTINUOUS VARIABLES

The benefit with this routine is that variables are listed below each other, with
different statistical measures listed next to each other. This makes it easier to
compare means, standard deviation, etc. for variables measured on the same
scale.
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NORMALITY

For additional descriptives, and to check normality of continuous variables.
Analyze > Descriptive Statistics > Explore

• Dependent list: The
variable/variables that you
wish to analyze

• Factor list: Categorical
variable that will group the
values in the continuous
variable(s)

• Label cases by: Typically the
ID variable, in order to identify
extreme cases more easily
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NORMALITY

Explore: Statistics

• Descriptives: Calculates mean,
confidence interval for the mean,
median, standard deviation, etc.

• M-estimators: Robust alternatives to
mean and standard deviation

• Outliers: Prints the five highest and
lowest values measured

• Percentiles: Finds 5%, 10%, 25%,
75%, 90% and 95% percentiles
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NORMALITY

Explore: Plots

• Boxplots: Factor levels together - If you have
provided a categorical grouping variable this
option will plot the groups together

• Boxplots: Dependents together -If you have
more than one dependent variable, these will be
plotted together

• Descriptive: Histogram is usually the most
useful choice

• Normality plots with tests: Plots and tables
which can make it more clear if a variable is
normally distributed or not
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NORMALITY

Explore: Options

• Exclude cases listwise: Excludes all cases
where one or more data point is missing
for any variable included in the analysis

• Exclude cases pairwise: Excludes only
those cases that are missing one or more
data point in the variable in question
included in the specific analysis

• Report values: When a factor variable is
chosen, empty cells will be treated as a
separate category
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NORMALITY

Output: Case Processing Summary and Descriptives

• Case Processing Summary: number
of cases, and how many valid

• Descriptives: Descriptive statistics.
Look e.g. at the difference between
mean and median to see if the mean
seems like a good measure of
central tendency. Skewness and
kurtosis are also useful. The
standard normal distribution has
skewness and kurtosis equal to 0.

71



NORMALITY

Output: Tests of Normality and Extreme Values

• Tests of Normality: Sigma greater
than 0.05 indicates normality.
HOWEVER, this is very rarely
achieved with large data sets. It is
usually better to look at the plots to
determine normality.

• Extreme values: The five greatest
and smallest values measured.
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NORMALITY

• Histogram: Here we see that
the data distribution is a bit
skewed, but the overall
distribution is close to a
normal distribution

• Boxplot: Shows much the
same as the histogram
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NORMALITY

• Normal Q-Q plot: The black line shows
where the data should be if it is perfectly
normal.Except for the right tail, the data lie
fairly close to the line

• Detrended normal Q-Q plot: This shows
the deviation between the data and the
normal distribution more clearly. There is
no clear trend in the deviation, which is a
good sign, but we see even more clearly
that the right tail is more heavy than
expected compared to the normal
distribution.
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USEFUL PROCEDURES

• Frequencies - distribution of answers for categorical variables, and much
descriptive statistics for continuous variables

• Descriptives - descriptive statistics for continuous variables, especially useful
for comparisons between variables

• Explore - All of the above, in addition to normality plots and tests, etc.
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GRAPHS AND FIGURES



MAKING GRAPHS IN SPSS

Graphs > Chart Builder

You choose which type of
graph you want to make, by
moving the selected type
from the gallery to the
preview window.
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HISTOGRAM

This type of graph is usually
used to present the
distribution of a continuous
variable.
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HISTOGRAM

Choose a continuous
variable you want to plot. By
also choosing Columns
panel variable under the
Groups/Point ID tab, you can
group data according to
groups in a categorical
variable.
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HISTOGRAM

This results in one histogram
for each group in the
categorical variable.
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HISTOGRAM

The two graphs have the
same scale on the y-axis,
which shows the frequencies
for intervals in the continuous
variable.
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BAR CHART

Useful when you wish to
show number of cases within
different groups in a
categorical variable, or to
display the average in a
continuous variable within
different groups.
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BAR CHART

By selecting two different
categorical variables, you
can make a clustered bar
graph. Tick Display error
bars in the Element
properties tab, when plotting
the mean of a continuous
variable.
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BAR CHART

The bars are separated into
three main groups, according
to the age variable, with two
bars of different colours for
each group, representing
men and women.
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LINE CHART

Often used to display
difference or development
over time or at different
experimental conditions,
within a continuous variable.
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LINE CHART

By selecting two different
categorical variables, we can
both have one indicating the
development (x-axis), and
one giving groups that will be
plotted as different lines.
Select Display error bars in
the Element properties tab.
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LINE CHART

In this case the different lines
for men and women could
help show if men and women
have similar or different
development patterns as age
increases.
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SCATTER PLOT

To show relation between
two variables, where at least
one of the variables is
continuous. A third
categorical variable can be
used to plot cases from
different groups as different
colours.
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SCATTER PLOT

This type of graph is useful to
look for correlation, as well
as extreme outliers. In
addition, it can show to some
extent if there are large
differences between groups.
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SCATTER MATRIX

If you wish to show relation
between more than two
continuous variables at the
same time, you can create a
scatter matrix.
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SCATTER MATRIX

Include all the variables you
are interested in. The
number of variables will
decide the size of the matrix.
With three variables, the
matrix will contain 3×3
smaller boxes with charts.
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SCATTER MATRIX

Under Options, choose
Exclude variable-by-variable
to include as many data
points as possible.
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SCATTER MATRIX

Which variables are plotted is
indicated by the axis labels.
In the top right corner, Total
positive affect is plotted
against Total perceived
stress. The graphs below the
diagonal are the same as the
graphs above it, only
mirrored.
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BOX PLOT

Like the histogram, it shows the data distribution, but it also shows the median,
interquartile range (IQR) as well as outliers.
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BOX PLOT

Useful to show similarities/differences between the distribution of a continuous
variable within different groups/categories.
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BOX PLOT

Cases that are more than 1.5 times the IQR from the box edge, are marked by a
circle, and are considered moderate outliers. Cases that are more than 3 times the
IQR from the box edge are marked by a *, and are considered extreme outliers.
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EDITING GRAPHS

Double click the graph in the
Output window. To change
font size, colours, direction of
axis labels, width of the bars,
change the y-axis, etc: Edit
> Properties. To change
direction of the bars,
background grid, include text
box, footnotes, etc: Options.
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EXPORT GRAPHS AND TABLES FROM SPSS

Copy to Word document. Simply right click on the graph, and select copy to paste
it directly into Word, or select Export to save as a separate file.
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EXPORT GRAPHS AND TABLES FROM SPSS

In Export Output
choose Selected and
Type: None (Graphics
only).
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EXPORT GRAPHS AND TABLES FROM SPSS

Choose the type of
image file you prefer.
You can export as
.jpg/.png/.eps.
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MANIPULATING DATA



RECODE A VARIABLE

Transform > Recode into Different Variables: NEVER choose Recode into Same
Variable, as you will lose the original information.
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RECODE A VARIABLE

Add the variables you wish to recode by selecting them from the list on the left and
clicking the blue arrow pointing to the right.
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RECODE A VARIABLE

Give new names to the new versions of the variables, and click on Change. Click
on Old and New Values.
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RECODE A VARIABLE

Recode into Different Variables: Old and New Values.
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RECODE A VARIABLE

Type in the old value on the left hand side, and the new value on the right hand
side, then click Add. The recoded values will appear as a list in the window Old
− > New.
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RECODE A VARIABLE

Check that the new variables are coded correctly, compared to the old ones.
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RECODE A VARIABLE: CONTINUOUS TO CATEGORICAL

How to recode a continuous variable into a categorical variable.

Transform > Visual Binning

Move the variable you wish to
recode into the window on the right
hand side, by selecting it and
pushing the blue arrow. Press
continue.
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RECODE A VARIABLE: CONTINUOUS TO CATEGORICAL

Here you can change the
label of your new categorical
variable if you wish. Press
Make Cutpoints to indicate
the number of categories,
and how they should be
divided.
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RECODE A VARIABLE: CONTINUOUS TO CATEGORICAL

Choose Equal Width Intervals,
Equal Percentiles Based on
Scanned Cases or Cutpoints at
Mean and Selected Standard...
Choose number of cutpoints.
Remember that the number of
categories equals the number of
cutpoints plus one. With three
cutpoints you get four categories.
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RECODE A VARIABLE: CONTINUOUS TO CATEGORICAL

Press Make Labels to get labels for your categories. Give your new variable a
name, and press Paste. Check that the new variable has values corresponding to
the correct categories, by comparing with the old continuous variable.
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RECODE A VARIABLE: TEXT TO NUMERICAL VARIABLE

Automatic recoding from text to numbers. We will use the data set manipulate.sav

Transform > Automatic Recode

Choose the variable that
should be recoded, and
mover it to the window on the
right hand side.
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RECODE A VARIABLE: TEXT TO NUMERICAL VARIABLE

Give the recoded variable a
new name and click Add
New Name. Choose if the
recoding should start from
the highest or lowest value. If
there are missing values, it is
useful to select Treat blank
string values as user
missing.
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RECODE A VARIABLE: TEXT TO NUMERICAL VARIABLE

Check that the recoding has worked
properly. Here the values will be recoded
according to their order in the alphabet,
with F being coded as 1 and M as 2.
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RECODE A VARIABLE: CALCULATIONS WITH DATES

In order to work with date
and time variables, we can
use the Date and Time
Wizard, and choose
Calculate with dates and
times.
Transform > Date and Time
Wizard
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RECODE A VARIABLE: CALCULATIONS WITH DATES

Add or subtract a duration...
can be used if you wish to
calculate a new date based
on one you already
have/know. Calculate the
number of time units... is
used to find the amount of
time between two dates.
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RECODE A VARIABLE: CALCULATIONS WITH DATES

Move the last date to Date 1.
Move the first date to Date 2.
This may seem
counterintuitive, but the
wizard will calculate Date
1-Date 2. Choose the
appropriate time unit (e.g.
days), and how you want to
handle smaller units (e.g.
round, truncate, decimal).
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RECODE A VARIABLE: CALCULATIONS WITH DATES

Give the new variable a
name, and if you wish to, a
label. Choose Paste the
syntax into the syntax
window.
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RECODE A VARIABLE: CALCULATIONS WITH DATES

Check if the new variable
seems to be correct. If you
only get 0, you have probably
just set the time unit to years
or similar. If you get negative
numbers, you have mixed up
Date 1 and Date 2.
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CALCULATE NEW VARIABLES

How to create a new variable from existing variables

Transform > Compute Variable

Give a new name to the new
variable, and fill in the
mathematical expression in
the box Numeric Expression,
using the calculator, the list
of existing functions and the
the list of existing variables.
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CALCULATE NEW VARIABLES

Click Type and Label to
provide a label for the new
variable.
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CALCULATE NEW VARIABLES

Check that the new variable looks correct.
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OUTLIERS?

Are some cases strange, or very far away from the rest of the data?

There are generally four main reasons for outliers:

1. Wrong coding

2. Wrong code for missing data, i.e. missing data is being treated as real data

3. The case belongs to a different population than the one you meant to sample

4. Greater dispersion/spread in the data than expected, and deviation from
the normal distribution
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TRANSFORMATION OF ’ABNORMAL’ DATA

My data are so far from a normal
distribution, what do I do?
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TRANSFORMATION OF ’ABNORMAL’ DATA

Use the same method as we used
to calculate a new variable. Use
the mathematical expression that
best fits with the distribution you
already have.
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BACK TO THE STUDY HALL/OFFICE

Start using SPSS as quickly as possible on your own data (or someone else’s for
that matter)!

The only way to improve your understanding of statistics and SPSS, is to use it.
Learning by doing.

Make sure you have good textbooks and online resources when you need to
check something.

A decent online tutorial can be found e.g. at https://libguides.library.kent.edu/SPSS

Ask google or youtube when you get stuck. If that doesn’t help, ask us
(statistikk@usit.uio.no) or attend our intermediate SPSS course, 27th - 29th of
September
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SUGGESTED BOOKS

In SPSS: SPSS Survival manual
by Julie Pallant

In statistics and SPSS: Discovering
statistics using IBM SPSS and An
adventure in statistics by Andy
Field
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COMMERCIAL BREAK

Are you struggling with large, unwieldy data sets? Does your computer lag and
struggle when you try to analyze them using SPSS? We have an introductory
course in R/RStudio!

Benefits: R and RStudio is free, it can do more than SPSS can, without the need
for a powerful computer. And also, that graphs look much better and more
professional :D
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