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FØR VI BEGYNNER...



LÆRINGSMÅL

1. Kjenne til de vanligste testene som kan brukes i statistisk analyse

2. Vite forskjell på parametriserte og ikke-parametriserte tester

3. Vite hvilke statistiske tester som bør brukes når

4. Vite når du må bruke robuste metoder

5. Kunne tolke resultatene fra en test i SPSS, og vite om en modell du har laget
er god eller ikke
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TEKNISKE FORUTSETNINGER

Hvis du ikke har SPSS nå, bruk remote desktop: view.uio.no

Data som brukes til eksempler og oppgaver er hentet fra SPSS survival manual,
og kan lastes ned fra https://www.allenandunwin.com/spss under Data Files &

Exercises eller fra kurssiden http://www.uio.no/for-
ansatte/kompetanse/tema/data/it-forskning/spss-26.02.19.html.

Prøv å gjøre og følge de samme stegene som jeg gjør underveis. Har du spørsmål
eller problemer, rop ut!
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TYPISKE FORUTSETNINGER FOR

ANALYSER



TILFELDIGHET

Alle deltakere/caser i et datasett bør så langt det lar seg gjøre være tilfeldig
utvalgt. Dette er en antakelse som all statistisk analyse har til felles.

Dersom individer ikke er tilfeldig utvalgt, vil man kunne få problemer med feilkilder,
og det blir vanskeligere å trekke generelle konklusjoner, fordi du ikke lenger kan
anta at utvalget ditt er representativt for populasjonen.
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UAVHENGIGHET

Målinger utført på samme person vil avhenge av hverandre. Målinger utført på
individer i samme gruppe, f.eks. medlemmer i en familie kan påvirke hverandre, og
vil ikke nødvendigvis være uavhengige.

I vanlig regresjonsanalyse må data være uavhengige.

For t-test og ANOVA finnes det spesielle løsninger når man har data fra samme
person over tid, eller under ulike testforhold (repeated measures).

Det er mer komplisert å komme rundt problemer der individer har påvirket
hverandre. Dette er utenfor hva vi rekker å gå gjennom på dette kurset.
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OUTLIERS/UTELIGGERE

Ekstreme verdier som skiller seg veldig mye fra resten av dataene vil alltid
ødelegge for tester/modeller, ettersom disse enkeltpunktene vil passe dårlig med
modellen, og dermed redusere målene på hvor god modellen er.

Hvis du har uteliggere, vurder om du skal transformere eller trimme datasettet (ta
bort de øverste og nederst 5%, 10%, etc), eller ta bort enkeltpunkter (hvis det ser
ut som dette er feilmålinger). Alternativt, bruk robuste metoder som ikke påvirkes
så mye av uteliggere.

Hvis du tar bort punkter MÅ du rapportere dette, og begrunne hvorfor. Det holder
ikke å si at de ikke passer med modellen. Det er modellen som skal tilpasses
dataene, ikke dataene som skal tilpasses modellen.
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LINEARITET OG ADDITIVITET

De fleste testene vi utfører antar et lineært forhold mellom variabler. Et
ikke-lineært forhold mellom variabler vil ikke nødvendigvis bli oppdaget, og en
modell som baserer seg på linearitet vil ikke passe godt til ikke-lineære forhold
mellom variabler.

Additivitet vil si at en modell basert på flere variabler best representeres ved at
effektene av disse variablene legges sammen.
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HOMOSKEDASTISITET/LIK VARIANS

Avvik mellom modellen du lager og dataene dine kalles gjerne for residualer. I
tillegg til at residualene bør være normalfordelt, bør de også være omtrent like
store gjennom hele modellen, altså ha konstant varians. Tilsvarende bør varians i
ulike grupper som sammenlignes, være relativt lik.

Hvis feilen modellen gjør endrer seg ettersom verdiene vi gir som input øker, har vi
ikke en homoskedastisk modell. Vi har et problem: heteroskedastisitet.
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NORMALITET ELLER NORMALFORDELING

De aller fleste tester antar at ett eller annet knyttet til dataene dine er normalfordelt
(enten at avvikene mellom rådata og modell er normalfordelt, eller at estimatene
du lager kommer fra en normalfordelt samplingsfordeling), og bruker dette til sin
fordel. Dette gjelder f.eks. t-test, ANOVA, Pearson-korrelasjon og lineær
regresjon.

På grunn av sentralgrenseteoremet vet vi at for store datasett (mer enn 30 caser),
vil samplingsfordelinger nærme seg en normalfordeling uansett. Har du mye
spredning eller uteliggere trenger du flere caser, og det er uansett lurt å ha minst
100 for å være trygg, aller helst flere.

Uansett kan det være en god idé å sjekke om dataene er normalfordelt før vi begir
oss ut på noe mer avansert statistisk analyse.
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NORMALITET

For å sjekke om dataene er normalfordelt bruker vi Explore Analyze > Descriptive
Statistics > Explore

• Dependent list:
Variabelen/variablene som du
ønsker å analysere

• Factor list: Kategorisk variabel
som kan gruppere data i den
avhengige variablen.

• Label cases by: Merke caser,
slik at f.eks. outliers blir enkle
å identifisere.
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NORMALITET

Explore: Plots

• Boxplots: Factor levels together - Dersom
det er angitt en faktor-variabel vil dette
velge å plotte dem sammen

• Boxplots: Dependents together - Dersom
man har valgt mer enn en avhengig
variabel, vil dette plotte dem sammen

• Descriptive: Histogram er som regel det
mest informative valget

• Normality plots with tests: Plott og tabeller
som kan gjøre det tydeligere om en
variabel er normalfordelt eller ikke
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NORMALITET

Output: Tests of Normality og Extreme Values

• Tests of Normality: For at disse skal
si at fordelingen er normal må sigma
være større enn 0.05. MEN, dette
skjer nesten aldri når man har store
datasett. Derfor er det bedre å se på
plottene for å avgjøre dette.

• Extreme values: De fem største og
minste verdiene.
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NORMALITET

• Histogram: Her ser vi at
dataene er litt skjevt
fordelt, men at den
overordnede fordelingen
er nær en
normalfordeling likevel

• Boxplot: Viser mye av
det samme som
histogrammet
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NORMALITET

• Normal Q-Q plot: Den skrå linjen
angir forventet verdi dersom
dataene var normalfordelt.
Unntatt i den høyre halen,
sammenfaller dataene og
normalfordelingen veldig bra

• Detrended normal Q-Q plot: Her
blir avvik mellom normalfordeling
og data tydeligere. Her er det
ingen klar avvikende trend, men
vi ser enda tydeligere at høyre
hale er ’tyngre’ enn forventet for
en normalfordeling
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HJELP, DATAENE MINE TILFREDSSTILLER IKKE FORUTSETNINGENE!

I en del tilfeller vil du kunne velge en ikke-parametrisert test, som ikke har disse
strenge forutsetningne

Trimme data: Ta bort de høyeste og laveste 5%, 10%, 15%, etc, alternativt trimme
basert på standardavvik

Windsorizing: Erstatte verdiene til ekstreme målinger, med den høyeste (eller
laveste) verdiene som ikke er en outlier

Bootstrapping: Lage seg mange hypotetiske sampler, basert på de verdiene man
allerede har, og gjøre de samme analysene på disse samplene

Transformere variabler som er milevis unna normalfordeling

14



BOOTSTRAPPING

Bootstrapping er en form for robust analyse, og er den som brukes oftest, og som
er enklest å implementere i SPSS.

Bootstrapping vil si at SPSS behandler ditt utvalg som en slags populasjon, som
den velger nye utvalg fra (med tilbakelegging). Den trekker N caser fra ditt utvalg,
regner ut de statistiske størrelsene vi har bedt om, og går videre til å gjøre dette på
nytt, til den har samlet 1000 (eller flere, det velger du selv) nye utvalg, som den
bruker som utgangspunkt til å lage konfidensintervaller rundt de estimerte
verdiene, f.eks. gjennomsnitt eller korrelasjonskoeffisient. Vanligvis tilsvarer N det
antall caser du har i ditt eget opprinnelige sample.
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TRANSFORMASJON AV ’UNORMALE’ DATA

Siste utvei, og kan
gjøre det vanskeligere
å tolke resultatene.
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ANTALL CASER/DATAPUNKTER

Det er ikke ett enkelt svar på hvor mye data du trenger for å kunne bruke en test,
eller forvente å finne signifikante svar på spørsmål. Det vil avhenge av typen test,
og størrelsen på effekten du undersøkter. Jo mindre effekt, jo flere caser trenger
du.

Sentralgrenseteoremet tilsier at selv om populasjonen du henter data fra ikke er
normalfordelt, vil estimatene dine ha normalfordelt sampliongsfordeling så lenge
du har minst 30 caser, men 30 er minstekravet, og stemmer ikke alltid.

Har du mye spredning i dataene dine, trenger du flere caser enn 30, og ser du
etter små effekter eller forskjeller mellom grupper, trenger du mange flere caser.
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UTFORSKE FORHOLD MELLOM

VARIABLER



KORRELASJON

Korrelasjon angir lineære forhold mellom to kontinuerlige variabler. Dersom to variabler er
korrelert vil en endring i den ene korrespondere med en endring i den andre.

Korrelasjon er et tall mellom -1 og 1, der 1 antyder perfekt korrelasjon. Hvis den ene
variablen øker, vil den andre øke tilsvarende.

Korrelasjon lik -1 er også en form for perfekt korrelasjon, men det antyder at om den ene
variablen øker, vil den andre minke tilsvarende. Dette er hva vi kaller negativ korrelasjon.

Korrelasjon lik 0 betyr at variablene ikke har noen sammenheng med hverandre. Om den
en øker, vil den andre oppføre seg helt vilkårlig.

Blir veldig påvirket av uteliggere

Pearson-korrelasjon er en parametrisert test, Spearman-korrelasjon er ikke-parametrisert.
Har du få caser, kan det være lurt å bruke Spearman.
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KORRELASJON
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FORUTSETNINGER FOR VANLIG KORRELASJON

Du trenger to (eller flere) kontinuerlige variabler som du skal teste for
sammenheng mellom

Forholdet mellom dem bør være lineært, for å finne noen sammenheng

Det burde ikke være noen utpregede uteliggere

Variablene bør være omtrent normalfordelt, men dette er kun viktig hvis du har
små datasett.

Hvis du ønsker å se på korrelasjon mellom ordinale og kontinuerlige variabler bør
du heller bruke Spearman eller Kendalls tau. Spearman er også å foretrekke når
du har mye outliers. Har du ikke normalfordelte data og med litt få caser, kan du
bruke bootstrap sammen med vanlig Pearson korrelasjon.
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KORRELASJON

Finne korrelasjon mellom to variable: Analyze > Correlate > Bivariate

Vi bruker datasettet
survey.sav. Angi variabler du
ønsker å finne korrelasjon
mellom. Pass på at Pearson
er haket av, og at Two-tailed
er valgt.
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HÅNDTERING AV MANGLENDE DATA

Velg Exclude cases pairwise, for å
inkludere mest mulig av dataene dine i
analysen.
Exclude cases listwise vil eksludere
enhver case som har manglende data i
seg, uavhengig av om dette punktet skal
brukes i analysen eller ikke.
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BOOTSTRAPPING

Dersom du ikke er helt sikker på om du
har nok data til at sentralgrenseteoremet
redder deg fra manglende
normalfordeling, så kan du be SPSS om
å kjøre en kjapp bootstrap samtidig
Hak av for Perform bootstrap, og angi
antall ganger. 1000 er default, og er som
regel nok, men om du vil kan du be om
2000 f.eks. Velg Bias corrected
accelerated.
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KORRELASJON

Ettersom vi utførte en bootstrap sammen
med korrelasjonsanalysen får vi med
noen ekstra rader, som angir
konfidenintervallene rundt estimatene
våre for gjennomsnitt og korrelasjon.
Konfidenintervallene støtter det
signifikansnivået angir, at vi har
signifikant korrelasjon, og at den i dette
tilfellet er stor. (Liten effekt: r≥0.1,
Middels: r≥0.3, Stor: r≥0.5).
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KORRELASJON

Finne gruppert korrelasjon mellom to variable

• For å finne
korrelasjon mellom
variable, i ulike
grupper, kan du
bruke Split File

• Data > Split File >
Compare groups
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PARTIELL KORRELASJON

Analyze > Correlate > Partial
Brukes for å se hvor
stor del av korrelasjon
skyldes sammenheng
med og variasjon i en
tredje variabel. Flytt de
variablene du er
interessert i over i
boksen Variables, og
den du vil kontrollere
for i Controlling for.
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PARTIELL KORRELASJON

Det er nyttig å hake av Zero-order
correlations. Dette gir et
sammenligningsgrunnlag, ettersom
SPSS også skriver ut korrelasjon mellom
variablene når man IKKE tar hensyn til
variasjonen i kontrollvariablen.
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PARTIELL KORRELASJON

Korrelasjon når man tar hensyn til en tredje variabel kan sammenlignes med
korrelasjon når man ikke tar hensyn. Er disse helt like, har kontrollvariablen ingen
innvirkning. I de fleste tilfeller vil korrelasjonen være litt lavere, noen ganger mye
lavere (confounding).
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LINEÆR REGRESJON

Brukes for å se etter sammenhenger mellom variabler. Kan du forutse en
kontinuerlig variabel basert på andre kontinuerlige data?

Finner bare lineære sammenhenger

Feilen vi gjør (avvik mellom utvalg og populasjon) må være uavhengige

Bør ha mange flere målinger enn variabler, tommelfingerregel er N>50+8m, der m
er antall uavhengige variabler, men dette er ikke noe fasitsvar

Mange tror at prediktorer/uavhengige variabler trenger å være normalfordelt, men
det er ikke tilfelle.

Avvik mellom målte verdier og predikerte verdier kalles residualer, og disse må
granskes litt ekstra i etterkant.
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ANTALL CASER

Antall caser du bør ha avhenger av
hvor mange uavhengige variabler
du ønsker å inludere i modellen, og
hvor stor (eller liten) effekten du
ser etter er. (Basert på figur hentet
fra Field, 2017)
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FORUTSETNINGER FOR LINEÆR REGRESJON

Du bør ha en kontinuerlig utfallsvariabel, og en eller flere kontinuerlige eller
dikotome kategoriske uavhengige variabler.

Det bør være en lineær sammenheng mellom utfallsvariablen og de uavhengige
variablene, og den samlede effekten bør kunne uttrykkes ved summen av
variablene.

Det bør ikke være noen utpregede uteliggere.

Observasjoner bør være uavhengige.

Dataene bør være homoskedastiske (sjekkes etter at du har laget modellen).

Residualene bør være normalfordelt (sjekkes etter at du har laget modellen).

Hvis du har mer enn en uavhengig variabel, bør disse ikke være sterkt korrelert
med hverandre, altså ingen multikolinearitet.
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LINEÆR REGRESJON

Analyze > Regression > Linear

Vi bruker datasettet
survey.sav. Flytt den
avhengige variablen
over til Dependent, og
start med et utvalg av
de uavhengige
variablene du vil ha
med i modellen i
boksen Independents.
Trykk på Next.
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LINEÆR REGRESJON

Legg til resten av variablene du vil
ha med i boksen Independents. Vil
du sammenligne med en enda mer
komplisert modell, trykker du på
Next enda en gang. Vil du ha med
alle variabler fra start, legger du
alle inn i første omgang, uten å
lage flere blokker.

33



LINEÆR REGRESJON

Linear Regression: Statistics
Pass på at Estimates og
Confidence intervals er haket
av i Regression Coeff., og ta
med Model fit, R squared
change, Descriptives, Part
and partial correlations,
Collinearity diagnostics og
Casewise diagnostics. Da får
du god oversikt over hvor
god modellen er.
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LINEÆR REGRESJON

Linear Regression: Options

La default-verdiene stå. Dette er
en av få analyser hvor det er bedre
å bruke Exclude cases listwise enn
Exclude cases pairwise. Bruker du
pairwise risikerer du at modellen
gir absurde (og fullstendige gale)
resultater, som at modellen din
forklarer mer enn 100% av den
totale variasjonene og den slags.
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LINEÆR REGRESJON

Linear Regression: Plots
Fordi residualene er det vi
har mest nytte av å se på
plotter vi standardiserte
predikerte verdier (ZPRED)
mot standardiserte residualer
(ZRESID). I tillegg velger vi
Historgram, Normal
probability plot og Produce
all partial plots.
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LINEÆR REGRESJON

Linear Regression: Save

For å undersøke om vi har
utpregede uteliggere, eller caser
som har stor påvirkning på
modellen, lagrer vi flere variabler
som knytter seg til residualene og
de estimerte verdiene. Disse vil bli
lagt til som egne variabler lengst til
høyre i datasettet.
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LINEÆR REGRESJON

Descriptives gir enkel beskrivende
statistikk for alle variabler, både
avhengig og uavhengige.
Correlations angir Pearson
korrelasjon mellom variablene. Her
kan man sjekke at de uavhengige
korrelerer med den avhengige,
samt at de uavhengige ikke
korrelerer veldig mye med
hverandre. Korrelasjon mellom
prediktorer på over 0.9 er ikke bra.
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LINEÆR REGRESJON

R Square angir hvor mye av
variabilitet i avhengig variabel som
beskrives av modellen (gang med
100 for å få %). ANOVA-tabellen
angir om modellen i sin helhet er
signifikant. I dette tilfellet er begge
signifikante, men modell 2
beskriver mer variabilitet.
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LINEÆR REGRESJON

Coefficients angir parametrene som forteller om effekten av hver enkelt variabel
(B), og om disse er signifikante (Sig.). Beta lar deg sammenligne effekten av hver
variabel mot hverandre, som om de var målt på samme skala. VIF er et mål på
multikolinearitet. Verdier over 10 er bekymringsverdige.
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LINEÆR REGRESJON

Spesielt målene på Mahal.
Distance og Cook’s Distance er
nyttige for å se etter uteliggere og
caser med på påvårkning på
modellen. Med fire uavhengige
variable er kritisk øvre verdi for
Mahalanobis 18.47. Det punktet
med Mahal. på 18.64 kan finnes i
datasettet, men er ikke så stor at vi
bekymrer oss. Kritisk verdi for
Cooks er 1. Alt under er greit.
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LINEÆR REGRESJON

Residualene er relativt
normalfordelt, så det er
liten grunn til å
bekymre seg for disse.
Hadde ikke det vært
tilfellet burde vi ha
prøvd å bootstrappe,
for å få mer pålitelige
konfidensintervaller og
signifikansnivåer
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LINEÆR REGRESJON

P-P plottet viser de
faktiske residualene
mot det man forventer,
gitt en normalfordeling.
Disse bør ligge langs
den svarte linjen, og
det gjør de, hvilket
forsterker argumentet
for at residualene er
normalfordelte.
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LINEÆR REGRESJON

Predikert verdi plottet mot
residualer brukes spesielt for
å sjekke om data er
homoskedastiske. Hvis
punktene har en trakt-form er
det tegn på
heteroskedastisitet, og vi bør
bruke robuste metoder.
Sky-form (sånn som her) er
det vi vil ha.
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LINEÆR REGRESJON

Siste sjekk av linearitet og korrelasjon er å se på scatterplot av alle uavhengige
variabler mot den avhengige variablen. Ikke overraskende ser vi lite tegn til
korrelasjon mellom utfall og de to variablene som ikke ga signifikans i modellen.
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LINEÆR REGRESJON

Ved å plotte standardiserte residualer mot de ulike uavhengige variablene kan vi
sjekke at feilen vi gjør ser uavhengig ut. Her bør det ikke være noen tydelige
trender.
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UTFORSKE FORSKJELLER MELLOM

GRUPPER



LITEN DISCLAIMER

Selv om t-test og ANOVA ofte presenteres som noe helt annet enn lineær
regresjon, er det egentlig akkurat det samme. Alt sammen baserer seg på den
samme lineære modellen. Grunnen til at de holdes separat, er rent historisk.
Derfor er det ikke så veldig farlig om du er usikker på om du vil utforske forskjeller
mellom grupper, eller forhold mellom variabler.
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T-TEST

Sammenligne data fra to grupper, for å se om de er forskjellige. Brukes typisk når
man har gjort kontrollerte studier.

Vær bevisst på at det finnes (i hovedsak) to ulike t-tester; en for uavhengige
grupper, og en for målinger på samme gruppe ved to tidspunkt (repeated
measures).

Alternativ dersom kriterier ikke er møtt: Mann Whitney U-test (for uavhengige
data), Wilcoxon Signed Rank-test (for avhengige data), t-test kombinert med
bootstrap.
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FORUTSETNINGER FOR UAVHENGIG T-TEST

Du trenger en kontinuerlig avhengig variabel og en kategorisk uavhengig variabel
med to nivåer/kategorier

Uavhengige observasjoner/grupper. Dette betyr at hver deltaker kun kan tilhøre en
av gruppene, f.eks. menn og kvinner, røykere og ikke-røykere.

Tilfeldig utvalg

Ingen utpregede uteliggere

Den avhengige variablen bør være normalfordelt innenfor hver av kategoriene i
den uavhengige variablen.

Variansen i den avhengige variablen bør være omtrent lik i de to kategoriene angitt
av den uavhengige variablen. Grupper bør heller ikke være veldig ulik størrelse.
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T-TEST

Analyze > Compare Means > Independent Samples T Test

Vi bruker datasettet survey.sav.
Flytt den avhengige kontinuerlige
variablen til boksen Test
Variable(s), og den uavhengige
kategoriske variablen til Grouping
Variable. Selv om du kan teste
flere avhengige variabler av
ganger, bør du ikke gjøre det, men
heller bruke MANOVA.
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T-TEST

Trykk på Define Groups...

Her gjelder det å huske hvordan
den kategoriske variablen er kodet.
Angi hva de to gruppene skal
være. Her er kjønn kodet som
1=Mann og 2=Kvinne, så vi angir 1
og 2 og trykker Continue. Hadde
de vært kodet som 0 og 1, ville vi
skrevet inn de verdiene.
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T-TEST

Group Statistics gir litt info om de to gruppene, gjennomsnitt, standardavvik, etc.
Independent Samples Test forteller oss om hvor stor forskjellen er (Mean
difference), og om den er signifikant (Sig. 2-tailed). Dersom Levene’s test ikke er
signifikant (kolonne nr 2), kan vi se på første rad (Equal variances assumed).
t-testen i dette tilfellet er ikke signifikant.
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MANN WHITNEY U-TEST

Ikke-parametrisert variant av vanlig t-test for uavhengige målinger. Du trenger en
kontinuerlig variabel, og en kategorisk variabel med to grupper. Alternativ om du
har mye outliers.

Analyze > Nonparametric Tests >
Independent Samples

Velg Customize analysis og trykk
på Fields
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MANN WHITNEY U-TEST

Velg Use custom field
assignments, og flytt den
avhengige variabelen over i
feltet Test Fields. Flytt den
uavhengige variablen over i
Groups, og trykk på Settings.
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MANN WHITNEY U-TEST

Hak av på Mann-Whitney U
(2 samples), og trykk Paste.
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MANN WHITNEY U-TEST

Sammendraget av testen forteller hva som er hypotesen vi tester mot (ingen
forskjell mellom grupper), og hva konklusjonen av testen er, basert på signifikans.
I dette tilfellet er det ikke signifikant forskjell mellom gruppene, og vi beholder
nullhypotesen.
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MANN WHITNEY U-TEST

Signifikans-verdien fra testen, med tilhørende test-statistikk vises i tabellen
Independent Samples Mann-Whitney U.... Histogrammene over de to gruppene
støtter resultatet av testen, at det ikke er noen stor forskjell mellom gruppene.
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FORUTSETNINGER FOR REPEATED MEASURES T-TEST

Du trenger en avhengig variabel som er kontinuerlig og målt ved to ulike tidspunkt
eller under to ulike forhold

Tilfeldig utvalg

Det bør ikke være noen utpregede uteliggere i differansen mellom de to
nivåene/tidspunktene

Forskjellen mellom målingene ved tidspunkt en og tidspunkt to bør være omtrent
normalfordelt.

Dataene bør være arrangert slik at alle deltaker kun har en rad, med målinger fra
ulike tidspunkt som ulike variabler.
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T-TEST (REPEATED MEASURES)

Analyze > Compare Means > Paired Samples T Test

Vi bruker datasettet
experim.sav. Flytt variablen
som inneholder målinger ved
tidspunkt/forhold nr 1 over i
boksen Paired Variables.
Flytt deretter variablen som
inneholder målinger fra
tidspunkt/forhold nr 2.
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T-TEST (REPEATED MEASURES)

Paired Samples Statistics inneholder beskrivende statistikk som gjennomsnitt og
standardavvik for de to ulike tidspunktene.Paired Samples Correlations angir
korrelasjon mellom målingene fra de to ulike tidspunktene.
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T-TEST (REPEATED MEASURES)

Siste tabell angir om testen er signifikant eller ikke, og hva som er gjennomsnittlig
forskjell mellom de to tidspunktene/forholdene. Her er forskjell 2.67, og testen er
høyst signifikant (p<0.001).
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WILCOXON SIGNED RANK-TEST

Ikke-parametrisert alternativ til repeated measures t-test. Du trenger en
kontinuerlig variabel målt ved to ulike tidspunkt. Spesielt egnet om du har mye
outliers.

Analyze > Nonparametric Tests > Legacy Dialogs > 2 Related Samples

Flytt først målinger fra
første tidspunkt over i
Test Pairs, deretter
målinger fra tidspunkt
nr 2. Hak av for
Wilcoxon.
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WILCOXON SIGNED RANK-TEST

Two-Related-Samples: Options

Hak av for Quartiles (og Descriptives om
du ønsker litt deskriptiv statistikk i
tillegg). Exclude cases test-by-test gjør
at alle som har data for begge tidspunkt,
men som eventuelt mangler data i andre
variabler fortsatt tas med i analysen.
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WILCOXON SIGNED RANK-TEST

Descriptive Statistics angir de ulike
kvartilene. Her ser vi at det er tegn til
forskjeller mellom målinger fra ulike
tidspunkt, ettersom alle kvartiler for
tidspunkt 2 er lavere enn for tidspunkt 1.
Test Statistics bekrefter dette (p<0.001).
Effekten kan beregnes vha r=z/(2*N) der
N er antall caser, som i dette tilfellet blir
-4.18/(2*30)=0.54, som tilsvarer en stor
effekt.
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ANOVA - ANALYSIS OF VARIANCE

Sammenligne data fra to eller flere grupper for å se om de er forskjellige.

Vær bevisst på at testen må tilpasses til om du har uavhengige grupper (ulike
deltakere i hver gruppe), eller om det er de samme som inngår i hver av gruppene
(repeated measures). ANOVA antar at alle grupper har omtrent like stor spredning
(standardavvik).

Alternativ dersom kriterier ikke er møtt: Kruskal Wallis-test, Friedman-test,
bootstrap, andre robuste metoder
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FORUTSETNINGER FOR UAVHENGIG ANOVA

Du trenger en kontinuerlig avhengig variabel, og en kategorisk uavhengig variabel
med minst to kategorier

Uavhengige målinger, slik at deltakere kun forekommer i en av gruppene angitt av
den kategoriske variablen, og enkeltindivider ikke har fått påvirke hverandre

Tilfeldig utvalg

Ingen utpregede uteliggere

Den avhengige variablen bør være omtrent normalfordelt innenfor de ulike
kategoriene angitt av den uavhengige variablen

Variansen til de ulike kategoriene bør være tilnærmet lik. Grupper bør heller ikke
være veldig ulik størrelse.
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ANOVA - ANALYSIS OF VARIANCE

Analyze > Compare Means > One way ANOVA

Vi bruker datasettet
survey.sav. Flytt den
avhengige variablen
over i vinduet
Dependent List, og den
kategoriske variablen til
Factor.

67



ANOVA - ANALYSIS OF VARIANCE

One way ANOVA: Options

Hak av for Descriptive, Homogeneity of
variance, Brown-Forsythe og Welch
under Statistics og velg Means plot. For
å få med mest mulig data i analysen,
velg Exclude cases analysis by analysis.
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ANOVA - ANALYSIS OF VARIANCE

One way ANOVA: Post Hoc Multiple Comparisons

Her kan du velge fra et utvalg av
post hoc-tester. Sjekk SPSS sin
dokumentasjon for detaljer om hver
test. Vi velger Tukey (hvis vi har
omtrent lik varians og størrelse på
grupper), Bonferroni (kontrollerer
for type I feil) og Games-Howell (i
tilfelle det er ulikhet i varians).
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ANOVA - ANALYSIS OF VARIANCE

Descriptives gir beskrivende statistikk for den avhengige variablen innenfor de
ulike gruppene definert av den uavhengige variablen.
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ANOVA - ANALYSIS OF VARIANCE

Test of Homogeneity... angir om vi kan
anta at variansen er omtrent like stor i de
ulike gruppene. Her er nullhypotesen at
de er like, så vi ønsker at Sig. skal være
større enn 0.05. Robust Tests of Equality
of Means angir testresultater som bør
brukes dersom variansen ikke er lik, og
angir omtrent det samme som vanlig
ANOVA. I dette tilfellet, at det er
signifikant forskjell mellom gruppene.
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ANOVA - ANALYSIS OF VARIANCE

Siden vi kan anta lik varians
baserer vi oss på vanlig ANOVA,
som også sier at det er signifikante
forskjeller mellom gruppene (Sig. =
0.01). Post hoc-testresultatene
angir hvilke grupper som er
signifikant ulike fra hverandre. Her
ser vi at det kun er signifikant
forskjell mellom første og siste
aldersgruppe.
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ANOVA - ANALYSIS OF VARIANCE

Gjennomsnitt i hver aldersgruppe plottet mot aldersgruppene indikerer også en
tydelig trend, med økende optimisme med alder.
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KRUSKAL WALLIS

Ikke-parametrisert alternativ til ANOVA for uavhengige målinger. Du trenger en
kontinuerlig variabel og en kategorisk variabel med tre eller flere grupper.

Analyze > Nonparametric parametric Tests > Independent Samples

I Fields-tabben, flytt den avhengige
variablen over i Test Fields, og den
kategoriske uavhengige variablen
til Groups.
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KRUSKAL WALLIS

Under Settings, velg
Kruskal-Wallis 1-way
ANOVA, og pass på at
Multiple comparisons står på
All pairwise. Velg Test for
Ordered Alternatives dersom
den kategoriske variablen er
ordnet. Trykk Paste.
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KRUSKAL WALLIS

Hypothesis Test Summary angir
hva null-hypotesen er, og om den
bør forkastes. I dette tilfellet sier
den at vi bør gå for alternativ
hypoteste, at det er forskjell på
gruppene og at den endrer seg
konsekvent ettersom alder øker.
Spesifikk test-statistikk og
signifikans vises også i
Independent-Samples
Kruskal-Wallis...
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KRUSKAL WALLIS

Boxplot av dataene fra
de ulike
aldersgruppene ser ut
til å bekrefte at
optimisme øker
ettersom alder øker.
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KRUSKAL WALLIS

Pairwise comparisons... forteller oss at det kun er signifikant forskjell mellom første
og siste aldersgruppe.
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FORUTSETNINGER FOR REPEATED MEASURES ANOVA

Du trenger en kontinuerlig variabel som er målt ved minst to ulike tidspunkt eller
eksperimentelle forhold

Tilfeldig utvalg

Ingen utpregede uteliggere

Den avhengige variablen bør være omtrent normalfordelt ved hvert av
tidspunktene eller ved hver av de ulike eksperimentelle oppsettene

Variansen til den avhengige variablen ved de ulike tidspunktene bør være
tilnærmet lik

Variansen til differansen mellom alle mulige par av tisdpunkter bør være tilnærmet
lik for alle parkombinasjoner (kalles ofte sfærisitet). Hvis ikke må korreksjoner
brukes.
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ANOVA - ANALYSIS OF VARIANCE (REPEATED MEASURES)

Analyze > General Linear Model > Repeated Measures

Vi bruker datasettet experim.sav.
Først må vi ’lage’ en faktor som
definerer effekter som skal testes
for flere personer/caser ved ulike
tidspunkt/forhold. Vi må bare oppgi
et navn og angi antall nivåer, og
trykke på Add.
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ANOVA - ANALYSIS OF VARIANCE (REPEATED MEASURES)

Etter at vi har trykket på Add, vil
denne faktoren dukke opp i vinduet
under. Deretter kan vi trykke på
Define.
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ANOVA - ANALYSIS OF VARIANCE (REPEATED MEASURES)

De tre nivåene i faktoren vi
lagde står listet opp som tre
ulike variabler. Disse må
defineres ved at vi markerer
nivå 1, og flytter målingene
av den avhengige variablen
ved tidspunkt 1 over i boksen
Within-Subjects Variables.
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ANOVA - ANALYSIS OF VARIANCE (REPEATED MEASURES)

Når alle tidspunkt er lagt til,
vil det se omtrent slik ut. Alle
tre nivåer i faktoren vår har
blitt definert av hver sin
variabel.
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ANOVA - ANALYSIS OF VARIANCE (REPEATED MEASURES)

Repeated Measures: Model

Sjekk at Full factoral er valgt,
og at Sum of squares står på
Type III.
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ANOVA - ANALYSIS OF VARIANCE (REPEATED MEASURES)

Repeated Measures: Options

Velg Descriptive statistics og
Estimates of effect size.
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ANOVA - ANALYSIS OF VARIANCE (REPEATED MEASURES)

Repeated Measures: Profile Plots

Flytt time over i Horizontal axis, og trykk
på Add. Velg enten Line chart eller Bar
chart (avhengig av hva du liker). Hak av
for Include Error Bars.
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ANOVA - ANALYSIS OF VARIANCE (REPEATED MEASURES)

Repeated Measures: Estimated Marginal Means

Velg time og flytt over i Display
Means for. Hak av for Compare
main effects og velg Bonferroni
(den er strengest). Trykk Continue
og Paste.
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ANOVA - ANALYSIS OF VARIANCE (REPEATED MEASURES)

Descriptive Statistics gir
gjennomsnitt og standardavvik for
den avhengige variablen innenfor
hver av gruppene definert av den
uavhengige variablen. Multivariate
Tests angir signifikans. Her kan du
velge den testen som er mest
vanlig i ditt fagfelt. Sig mindre enn
0.05 indikerer signifikant forskjell
mellom grupper.
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ANOVA - ANALYSIS OF VARIANCE (REPEATED MEASURES)

Mauchly´s test of sphericity angir om sfærisitet er tilfredsstilt eller ikke.
Nullhypotesen er at sfærisitet er tilfredsstilt. Hvis Sig. er mindre enn 0.05, kan vi
ikke anta at sfærisitet er tilfredsstilt, og vi må da ta hensyn når vi tolker resten av
modellen.
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ANOVA - ANALYSIS OF VARIANCE (REPEATED MEASURES)

Siden vi ikke kan anta sfærisitet,
må vi basere oss på de tre andre
målene på om det er forskjeller på
tidspunktene. Den strengeste er
Lower-bound, og selv denne er
signifikant. Vi har også signifikans
for at det er en lineær
sammenheng med tidsfaktoren vår
(se Tests of within-subjects
contrasts-tabell)
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ANOVA - ANALYSIS OF VARIANCE (REPEATED MEASURES)

Gjennomsnitt for hvert tidspunkt sammen
med tilhørende standardfeil of
konfidensintervall er presentert i
Estimated Marginal Means. Pairwise
comparisons viser at det er signifikant
forskjell mellom alle nivåer, med
tilhørende gjennomsnittlig forskjell.
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ANOVA - ANALYSIS OF VARIANCE (REPEATED MEASURES)

Gjennomsnitt for hvert tidspunkt plottet mot tid, inludert usikkerhet gitt av
konfidensintervallene viser en tydelig lineær trend i at deltakeres frykt for statistikk
avtar med tid.
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FRIEDMANS ANOVA

Ikke-parametrisert alternativ til repeated measures ANOVA. Du trenger en
kontinuerlig variabel som har blitt målt ved minst to ulike tidspunkter/ulike forhold.

Analyze > Nonparametric Tests > Legacy Dialogs > K Related Samples

Flytt de variablene som
representerer målinger på
ulike tidspunkt/under ulike
forhold over i boksen Test
Variables.
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FRIEDMANS ANOVA

Several Related Samples:
Statistics, Several Related
Samples: Exact

Hak av for Quartiles og eventuelt
Descriptive om du vil. Velg Exact
under Exact tests.
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FRIEDMANS ANOVA

Deskriptiv statistikk viser kvartiler
ved hvert tidspunkt. Ranks angir
gjennomsnittlig rang ved hver av
de tre tidspunktene. At rang ser ut
til å avta med tid antyder at det er
en sammenheng mellom tid og
frykt for statistikk. Test Statistics
angir om testen er signifikant eller
ikke (Asump. Sig.< 0.05).
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MIXED ANOVA

Brukes når du har lyst til å både sammenligne uavhengige grupper, samtidig som
du har målinger utført på de samme individene ved flere tidspunkt/ved ulike
forhold.

Analyze > General Linear Model >
Repeated Measures

Som med vanlig repeated measures
ANOVA, må vi lage faktoren som angir
de ulike tidspunktene/forholdene. Gi den
et navn, angi antall nivåer, og trykk Add,
og trykk Define
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MIXED ANOVA

Flytt de variabene som tilsvarer
målinger av den avhengige
variablen på ulike tidspunkt over til
tilsvarende nivå i tidsfaktoren i
vinduet Within-subjects variables.
Flytt faktoren som angir den
faktoren med uavhengige målinger
over i feltet Between-subjects
factors.

97



MIXED ANOVA

Repeated Measures:
Options

Velg Descriptive statistics,
Estimates of effect size og
Homogeneity tests.
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MIXED ANOVA

Repeated Measures: Profile Plots

Legg til den repeterte faktoren (her time)
til feltet Horizontal Axis, og faktoren med
uavhengige grupper i boksen Separate
Lines, og trykk på Add. Velg Line Chart,
og hak av for Include Error Bars.
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MIXED ANOVA

Gjennomsnitt og
standardavvik for de to
uavhengige gruppene
ved hvert av de tre
tidspunktene.
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MIXED ANOVA

Dette er en test av kovarians på tvers av
grupper og tidspunkt. Nullhypotesen er at
kovariansen er lik. Hvis denne testen ikke er
signifikant, kan vi anta at kovariansen ikke
varierer nevneverdig, dvs. at korrelasjon
mellom ulike tidspunkter innenfor
undergruppene definert av de uavhengige
gruppene ikke varierer.
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MIXED ANOVA

De første fire radene i
Multivariate tests tilsier at det
er en signifikant effekt av tid.
De neste fire radene tilsier at
det ikke er noen signifikant
effekt av den kombinerte
faktoren tid og gruppering.
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MIXED ANOVA

Levene´s test antyder at det er
konstant varians i feilen som
modellen gjør, ettersom ingen av
testene er signifikante. Tests of
Between Subjects effects viser at
gruppene i den uavhengige
variablen ikke er signifikant ulike
(p=0.81).
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MIXED ANOVA

Grafen av frykt for statistikk over tid for de to ulike gruppene forsterker inntrykket
av at det ikke er noen forskjell på gruppene, ettersom linjene følger hverandre
veldig nært.
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ANOVA - ANALYSIS OF VARIANCE

Andre varianter av ANOVA

• Two way ANOVA - flere uavhengige kategoriske variable. Resultatet blir å se
på forskjeller mellom ulike grupperinger, f.eks. ikke bare kjønn, men
aldersgruppe også.

• ANCOVA (ANalysis of COVAriance) - Utføre ANOVA, mens du tar hensyn til
en eller flere kontinuerlige variabler også

• MANOVA (Multippel ANOVA) - Se på forskjeller mellom grupper, innenfor flere
kontinuerlige avhengige variabler samtidig
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KATEGORISKE UTFALL



CHI SQUARED(χ2)-TEST

Brukes for å teste om fordelingen av data innenfor kategorier er tilfeldig eller ikke,
altså om det er en korrelasjon mellom kategoriske variabler.

Dette er en ikke-parametrisert test, så her trenger vi ikke tenke så mye på
fordeling av data. Derimot bør ingen av gruppene i de kategoriske variablene være
for små. Hvis du ser på sammenheng mellom to kategoriske variabler med to
grupper i hver, resulterer dette i 2 × 2 = 4 undergrupper. Da bør ingen
undergrupper ha en forventet frekvens under 5. For større tabeller bør minst 80%
av cellene ha forventet frekvens på 5 eller mer.

Observasjoner bør være uavhengige, så de to variablene bør f.eks. ikke være av
typen pre/post-test. Hvis du har slike data bør McNemar’s test brukes istedenfor.
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CHI SQUARED(χ2)-TEST

Analyze > Descriptive
Statistics > Crosstabs...

Bruker datasettet survey.sav.
Flytt en av de kategoriske
variablene over i Row(s) og
den andre over i Column(s).
Hak av for Display clustered
bar charts hvis du vil.

107



CHI SQUARED(χ2)-TEST

Crosstabs: Exact

Velg Exact fremfor Asymptotic
only. Da regner du ut Fisher’s
exact test, som er gunstig hvis man
har få caser, eller lave forventede
frekvenser i enkeltgrupper. Hvis
dette ikke er tilfellet, vil det heller
ikke utføres noen korreksjon, så du
taper ingenting.
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CHI SQUARED(χ2)-TEST

Crosstabs: Statistics

Hak av Chi-square, Contingency
coefficient, Phi and Cramer’s V og
Lambda, så vi får utført riktig test
(χ2) og får et mål på effektstørrelse
(Phi/Cramers V). Lambda gir et
mål på i hvor mye mindre feil vi får
om medlemskap i en variabel
predikeres basert på medlemskap i
den andre variablen.
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CHI SQUARED(χ2)-TEST

Crosstabs: Cell Display

Hak av for både Observed og
Expected i Counts. I tillegg hak av
for Row, Column og Total i
Percentages, og Standardized i
Residuals.
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CHI SQUARED(χ2)-TEST

Krysstabellen gir hvordan
deltakere fordeler seg i de (i dette
tilfellet) fire undergruppene,
sammen med et forventet antall.
Residualene angir forskjell mellom
målt frekvens of forventet. Hvis
residualene er større enn 2.0 (for
en 2×3 tabell eller større), er det
mye større forskjell enn forventet.
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CHI SQUARED(χ2)-TEST

Liten effekt: 0.1, Middels effekt:
0.3, Stor effekt: 0.5.

Den viktigste verdien i Chi-Square
Tests Pearson Chi-Square. Siden
denne ikke er signifikant, er det
ikke forskjell på antall menn og
kvinner som røyker. Med 2×2
tabell er phi best mål på effekt,
ellers er det Cramers V.
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CHI SQUARED(χ2)-TEST

Søylediagrammet forsterker
inntrykket av at det ikke er
noen signifikant forskjell
mellom hvor mange som
røyker av menn og kvinner,
ettersom begge grupper ser
nesten like ut.
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LOGISTISK REGRESJON

Brukes når du har en kategorisk avhengig variabel, altså når du prøver å forutse
gruppemedlemskap basert på andre kontinuerlige og/eller kategoriske variabler

Ikke avhengig av normalfordeling, men det er viktig at alle grupper/kategorier har
nok datapunkter

Her er også multikolinearitet mellom uavhengige variabler viktig å passe på.
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FORUTSETNINGER FOR LOGISTISK REGRESJON

Du har en avhengig variabel som er kategorisk, der kategoriene ikke overlapper.
Det kan ikke være mulig i tilhøre mer enn en av utfallskategoriene.

Du har en eller flere uavhengige variabler som er kontinuerlige eller kategoriske

Observasjonene er uavhengige

Hvis du har flere kontinuerlige uavhengige variabler, bør disse ikke være korrelert

Alle kategorier i en kategorisk variabel bør være skikkelig representert

Lineært forhold mellom kontinuerlige prediktorer og logit-tranformasjonen av
utfallsvariabel
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LOGISTISK REGRESJON

Analyze > Regression > Binary Logistic

Vi bruker datasettet
sleep.sav. Flytt den
avhengige variablen til
Dependent og de ønskede
uavhengige variablene til
Covariates. Trykk på
Categorical...
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LOGISTISK REGRESJON

Logistic Regression: Define Categorical Variables

Alle kategoriske variabler må
spesifiseres, slik at de
behandles på riktig måte i
modellen. Her kan du velge
om referansegruppen skal
være første eller siste
gruppe, men husk å trykke
på Change, ellers skjer det
ingen endring.
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LOGISTISK REGRESJON

Logistic Regression: Options

Hak av for
Hosmer-Lemeshow
goodness-of-fit, Casewise
listing of residuals, CI for
exp(B) og Include constant in
model. Trykk Continue og
Paste.
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LOGISTISK REGRESJON

Første del av output angir bare litt
innledende om hvor mange caser
som er tatt med i analysen, og
hvordan den avhengige variabelen
er kodet. Dette er praktisk å huske
på når man skal tolke resten av
resultatene. Referanse-gruppen for
utfall er kodet som 0, i dette tilfellet
no.
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LOGISTISK REGRESJON

Tilsvarende koding for de
uavhengige (kategoriske)
variablene, med frekvens for hver
gruppe. Grupper kodet som 0 er
referansegrupper, fordi vi valgte
første gruppe som referanse.
Classification tabel gir resultatene
av den modellen vi sammenligner
med, nemlig den uten noen
variabler innkludert.
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LOGISTISK REGRESJON

Omnibus test angir modellens
signifikans, som helst skal være under
0.05. Cox & Snell R Square og
Nagelkerke R Square anslå hvor mye
variasjon i utfallet som beskrives av
modellen. Hosmer-Lemeshow angir om
modellen er god. Her vil vi ha Sig. større
enn 0.05.
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LOGISTISK REGRESJON

Til sammenligning med den tomme
modellen, kan vi nå med denne modellen
korrekt forutse 75,1% av resultatene,
sammenlignet med 57.3%. For de
resultatene som ikke forutses korrekt,
har de med residualer større enn 2 blitt
listet i Casewise list. Er residualene
større enn 2.5 bør disse undersøkes
nærmere. Det kan være en grunn til at
disse ikke beskrives bra av modellen.
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LOGISTISK REGRESJON

Selve modellen vises i Variables in the Equation.Kolonnene B og Exp(B) angir
effektstørrelse, og Sig. signifikans. Hvis Exp(B) er større enn 1 for en spesifikk
variabel, betyr det at sjansen for å ende opp i gruppe 1 i utfallsvariablen, er større
om man enten øker verdien av variablen (kontinuerlig), eller går fra
referansegruppe til ikke referansegruppe for den variablen. De som har problemer
med å få sove (prob fall asleep=1) har 2.05 ganger høyere odds for å ha
søvnproblemer (prob sleep=1).
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LOGISTISK REGRESJON

For å teste linearitet, kan man regne ut den naturlige logaritmen til alle
kontinuerlige variabler (LN(age), LN(hourwnit)). Kryssleddene
LN(variabel)×variabel inkluderes så i den logistiske regresjonsmodellen. Hvis
disse leddene ikke er signifikante, er antagelsen tilfredsstilt.
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LOGISTISK REGRESJON

For å teste for multikolinearitet, må man bruke vanlig lineær regresjon, med
akkurat de samme variablene som avhengig og uavhengig variabler som i den
opprinnelige modellen, og hake av for Collinearity Diagnostics under Statistics i
dialogboksen. VIF<10 er nødvendig.
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TILBAKE TIL LESESALEN/KONTORET

Begynn å bruke SPSS så fort som mulig på egne data (eller andres data om du
vil)!

Den eneste måten å bli god i statistikk og SPSS er ved å bruke det.

Sørg for å ha gode oppslagsverk

Spør google og youtube når du står fast. Står du fortsatt fast, spør oss
(statistikk@usit.uio.no)
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FORSLAG TIL BØKER

I SPSS: SPSS Survival manual av
Julie Pallant

I statistikk og SPSS: Discovering
statistics using IBM SPSS og An
adventure in statistics av Andy
Field
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